Skidoo Turbo Issue with bogging at times Deep Snow

rknight111

Administrator
Administrator
Moderator
Joined
Sep 27, 2006
Messages
11,956
Reaction score
15,231
Location
Parkland County, AB and Valemount, BC
Website
www.snowandmud.com
Possibly be the program in ECU
Not sure, no codes are being thrown as far as I know. I will ask if they can re-flash this as well. They have to do as BRP askes them but BRP doesn't seem to care that the end user is going out and having a OK ride on a day when it should be a killer ride.
 

rknight111

Administrator
Administrator
Moderator
Joined
Sep 27, 2006
Messages
11,956
Reaction score
15,231
Location
Parkland County, AB and Valemount, BC
Website
www.snowandmud.com
Spark plug wires and caps. The backfiring is an ignition issue with fuel being introduced with poor or non existent spark. Cheap to try and I’ve seen these plug wires cause numerous issues and always under heavy load.
Is there better wires available for these units. Part numbers, or do you change them to good aftermarket ones.
 

snoflake

Active VIP Member
Joined
Oct 15, 2008
Messages
542
Reaction score
1,863
Location
Red Deer
We had a sled acting up similar to what your describing and it was the charge tube. Have also heard of the doo ones being prone to cracking? Bikeman is selling them.

 

rknight111

Administrator
Administrator
Moderator
Joined
Sep 27, 2006
Messages
11,956
Reaction score
15,231
Location
Parkland County, AB and Valemount, BC
Website
www.snowandmud.com
We had a sled acting up similar to what your describing and it was the charge tube. Have also heard of the doo ones being prone to cracking? Bikeman is selling them.

I have one I am taking it to martins and they are installing it, bought it last season. thx.
 

brian h

Active VIP Member
Joined
Jul 21, 2009
Messages
722
Reaction score
1,039
Location
edmonton alberta
I have rode with Ron lot's and it does not matter what the fuel tank level is at for those asking. When riding with 6 doo's in the group and only his does this it's not the exhaust for the other machines are in the same snow conditions for those thinking plugged exhaust. As for Maxwell suggesting do a video we did that last season and let dealer see last season. That's when they did the injectors. The thing that I have watched while we ride and noticed is almost every time when it acts up he leaves a trail of black in the snow from the exhaust, with the longer he stays on the throttle the darker the snow gets.
 

snoflake

Active VIP Member
Joined
Oct 15, 2008
Messages
542
Reaction score
1,863
Location
Red Deer
Well I hope they get it sorted out. I have been there before with a problem that nobody can seem to fix. Be sure to post if/when the problem gets solved.


I have one I am taking it to martins and they are installing it, bought it last season. thx.
 

oler1234

Active VIP Member
Joined
Nov 20, 2008
Messages
3,166
Reaction score
4,475
Location
Calgary, AB & Golden, BC
cIs there better wires available for these units. Part numbers, or do you change them to good aftermarket ones. Yea

I am assuming you have pulled a plug to ensure it’s not fouled plug.

As for spark plug wires, get a MSD plug wire kit and fabricate your own. They arep shielded and will work. I have used them in the past.

That said ensure plug wires are hooked on. They may look like it but sometimes they vibrate off.

If dropping off at Martin’s get them to pressure test the exhaust pressure sensors.
 

MK4TDI

Active VIP Member
Joined
Dec 5, 2010
Messages
2,831
Reaction score
10,919
Location
Saskatchatoon
I have rode with Ron lot's and it does not matter what the fuel tank level is at for those asking. When riding with 6 doo's in the group and only his does this it's not the exhaust for the other machines are in the same snow conditions for those thinking plugged exhaust. As for Maxwell suggesting do a video we did that last season and let dealer see last season. That's when they did the injectors. The thing that I have watched while we ride and noticed is almost every time when it acts up he leaves a trail of black in the snow from the exhaust, with the longer he stays on the throttle the darker the snow gets.
That almost sounds like what it would look like when the Rave Valves on the XM's were acting up. But they would at least throw a rave valve code of some sort.
 

ABMax24

Active VIP Member
Joined
Sep 10, 2013
Messages
3,191
Reaction score
7,142
Location
Grande Prairie, Alberta, Canada
If dropping off at Martin’s get them to pressure test the exhaust pressure sensors.

I agree with this. It sounds like its sensor related, for whatever reason the ECU believes the engine is getting more air than it actually is when buried in snow and is causing the mixture to go extremely rich.

I'd also check/replace the intake air temp/manifold pressure sensor as well, as it is also a likely cause of this issue and relatively cheap.

As far as I'm aware these turbos don't run a mass airflow sensor, but the symptoms sound exactly like when a hot wire MAF gets wet, the indicated airflow reading goes sky high and the ECU dumps tons of fuel to prevent a lean burn down.
 

Merc63

Active VIP Member
Joined
Aug 24, 2014
Messages
1,710
Reaction score
2,557
Location
Alberta
^ yep. it’s running too rich if it’s leaving the snow black out the exhaust, that’s raw fuel. Also indicating it happens in deep snow when the vents are covered. It’s not getting enough air and it can’t seem to adjust the fuel accordingly.

How do these ecu calculate air intake amounts?
 

RGM

Active VIP Member
Joined
Nov 1, 2009
Messages
1,600
Reaction score
3,407
Location
Pemberton
Only problem I had with my turbo was plugged fuel pump screen and filter. I don't know why skidoo doesn't have a fuel pressure senor on them that would throw a code when the PSI drops below a certain #. In deep snow on older sleds I have had bogging when turning right due to heavy snow plugging exhaust.
 

RGM

Active VIP Member
Joined
Nov 1, 2009
Messages
1,600
Reaction score
3,407
Location
Pemberton
I have this issue often last season, and I can be with a group of 4 of the same sleds so why wouldn't this happen to all the others at the same time? I tried everything from going to better fuel even. Just before last ride they changed some injectors, I went out and never appeared to have the issue in some pretty good snow. Thought it was fixed and NOPE, still at its same thing. Bringing into Martins tomorrow, there going to have a peek again, and inspect the reeds for any damage from all the recent backfiring.
You need to have someone take a vid and post it. Just hearing what it sounds like can be a big help in diagnosing
 

rknight111

Administrator
Administrator
Moderator
Joined
Sep 27, 2006
Messages
11,956
Reaction score
15,231
Location
Parkland County, AB and Valemount, BC
Website
www.snowandmud.com
Ray, this is something that is very sporadic, it happened twice in one day. I'll have to get the GoPro set up and keep filming eventually I will get it. Last year I had BrianH try to film it do it and it wouldn't do this. I will keep dropping this off and trying to fix things, I will even change my spark plug wires. I went through this all last season and with 2600 km already, I'm hoping I can fix this early this season, I need to get this bug out and working properly. Warranty is 2 years and I shouldn't have to have to buy a third year due to this issue.
 

ctd

Active VIP Member
Joined
Dec 14, 2016
Messages
247
Reaction score
660
Location
In Elevation
One issue I've always had with BRP is the inability to data log, maybe that has changed. I would suggest quizzing them to see if it is possible to have a black box connected. It might not give the final answer, it would provide significant clues.

Failing that there are two aftermarket flash tuners that are capable of doing what I've just described, one is heavily loaded with diagnostic software. It can data log, read & clear codes as well as program keys. Interface with all BRP products. I've used this in limited fashion with Sea Doo, with Sea Doo you can build your own calibrations & flash. It has that capability as well with Ski Doo, talking with the manufacturer I'm not sure they will release that with E TEC.

The second flash tuner will data log & or tune your turbo. No other capabilities listed above, no codes or key programming.

This does not solve your problem, it gives you the ability to dig deeper rather than guessing. It's a deficiency with BRP that I've discussed many times, data logging is very common place in the automotive world. Critical for diagnosing normal problems & priceless for intermittent problems such as you are experiencing.
 

Caper11

Active VIP Member
Joined
Oct 28, 2007
Messages
7,872
Reaction score
14,349
Location
Edson,Alberta
The boost tube should be checked, regardless if an aftermarket one is going on, throttle cable, wastegate. A ECM file should of been requested from BRP
 
Top Bottom