• Please complete the Poll for the Edmonton Snow Show After Party found in Snowmobile chat

Quick 9r review

jhurkot

Active VIP Member
Joined
Nov 2, 2008
Messages
3,038
Reaction score
10,992
Location
Monarch, AB
Checked my primary bolt at about 300 miles. I retorqued it to 110ft/lb. Look how much it moved…

f48877a684b50c99432a8d2b9f8b8422.jpg



Sent from my iPhone using Tapatalk
 

gedakbx

Active VIP Member
Joined
Feb 26, 2010
Messages
674
Reaction score
1,032
Location
central alberta
Carry a spare bolt and you will never need it. We did need one last year and never had one now we have one in each sled
 
Last edited:

jhurkot

Active VIP Member
Joined
Nov 2, 2008
Messages
3,038
Reaction score
10,992
Location
Monarch, AB
Carry a spare bolt and you will never need it. We did need one last year and never had one now we have one in each sled

It’s a 2 piece clutch so if the bolt is lose it will strip the splines. Also a lose bolt could break and it’s not fun getting the threaded part out of the crank. Can’t buy a bolt from Polaris they are backordered but if you need one for warranty work they are available.


Sent from my iPhone using Tapatalk
 

gedakbx

Active VIP Member
Joined
Feb 26, 2010
Messages
674
Reaction score
1,032
Location
central alberta
We got a boost out last year after the bolt broke. We used a piece of all thread and a nut and yes it did mess the splines up but we got it together and rode it out.
 

Jorgy

Active VIP Member
Joined
Nov 26, 2013
Messages
841
Reaction score
1,700
Location
Leduc County
So I rode two days with the 74's. Around 6000' was pulling 8500 rpm still. Following Polaris chart so just gonna run it and see what happens...
 

jhurkot

Active VIP Member
Joined
Nov 2, 2008
Messages
3,038
Reaction score
10,992
Location
Monarch, AB
So I rode two days with the 74's. Around 6000' was pulling 8500 rpm still. Following Polaris chart so just gonna run it and see what happens...

Stock spring?


Sent from my iPhone using Tapatalk
 

jhurkot

Active VIP Member
Joined
Nov 2, 2008
Messages
3,038
Reaction score
10,992
Location
Monarch, AB
yup. areas south and north of revy. Soft base about 1 foot of dryish snow

Try 120/320 primary spring with the 74s if you still over rev. The 120/320 with stock 72s is pretty bang on for my 165.


Sent from my iPhone using Tapatalk
 

jhurkot

Active VIP Member
Joined
Nov 2, 2008
Messages
3,038
Reaction score
10,992
Location
Monarch, AB
Checked my clutch alignment yesterday and it was out by a bit. I’ve heard some are pretty far out. Must have got over looked on the $800 PDI.


Sent from my iPhone using Tapatalk
 

banditelectric

Active VIP Member
Joined
Oct 31, 2009
Messages
211
Reaction score
558
Location
Caroline, Alberta, Canadia, Earth, Milkyway
Checked my clutch alignment yesterday and it was out by a bit. I’ve heard some are pretty far out. Must have got over looked on the $800 PDI.


Sent from my iPhone using Tapatalk
Ive heard a couple tales now of fellas whose Primary has blown right off on the 9R...one of which o good friend of mine posting a video of him walking home...Sounds like typical Polaris quality control (or lack there of) issues.
 

LUCKY 7

Active VIP Member
Joined
Jan 17, 2009
Messages
4,322
Reaction score
6,645
Location
Sparwood
Ive heard a couple tales now of fellas whose Primary has blown right off on the 9R...one of which o good friend of mine posting a video of him walking home...Sounds like typical Polaris quality control (or lack there of) issues.
no pics didn't happen
 

Jjanke

Active VIP Member
Joined
Apr 24, 2013
Messages
204
Reaction score
534
Location
Edmonton alberta
Buttons fell out of my spider. Didn’t even make 500 miles on the POS p22 clutch.

f45319ca0f93f4322de0c00116cf9bf4.jpg


P85 on now.

Sent from my iPhone using Tapatalk

Same thing happened to mine today… 368 miles… you know if anyone in town may have these Johnny?


Sent from my iPhone using Tapatalk
 
Top Bottom