No support from a dealership

WhiteDragon

Active member
Joined
Sep 19, 2008
Messages
65
Reaction score
32
Location
Alberta
I started one thread about Argyll. Here is another.
I had purchase a NEW TW200 from Argyll, and had to do a Out of Province inspection because the NVIS was voided. I also had to pay for repairs on the new motorcycle because it failed the inspection.
Now, the motorcycle is back at the dealership (for the 5th time) because it does not run. They have had the motorcycle for over a month, and currently, it is not even SCHEDULED to be looked at-let alone have any work done on it. The motorcycle does not even have the mileage for the initial service-simply because it does not run.
Right now, I am advising anybody reading this to avoid going to Argyll. Customer support is obviously not a priority there.
 

ABMax24

Active VIP Member
Joined
Sep 10, 2013
Messages
3,122
Reaction score
6,858
Location
Grande Prairie, Alberta, Canada
I had purchase a NEW TW200 from Argyll, and had to do a Out of Province inspection because the NVIS was voided. I also had to pay for repairs on the new motorcycle because it failed the inspection.

That sounds really shifty, how was the NVIS voided, was it stolen while still new and is now being resold?
 

d mills

Active VIP Member
Joined
Nov 10, 2009
Messages
3,274
Reaction score
4,974
Location
camrose
That sounds really shifty, how was the NVIS voided, was it stolen while still new and is now being resold?
If I recall the other thread the details coming from whitedragon are just as shifty........
 

the_real_wild1

Active VIP Member
Joined
Oct 13, 2010
Messages
6,971
Reaction score
7,396
Location
cardiff
OMFG I thought you had this resolved already. Cut your loses already. Something doesn't add up, and you have already lost credibility here posting about it. You are wasting your time and now mine for posting this. I want my two minutes back.
 
Top Bottom