Let's get a real km to belt usage tally

teamdirt

Active VIP Member
Joined
Dec 17, 2008
Messages
692
Reaction score
1,075
Location
revy/sicamous
Btw- 165-3" purchased from motor tech

500km on original belt- no issues what so ever.
pulled felt and foam and drilled holes in clutch cover and clutch side panel around 350km after reading about all the belt issues on S&M
 

murdok

Member
Joined
Jul 27, 2008
Messages
13
Reaction score
12
Location
Andrew, Alberta
image.jpeg Just got back fro grizzly lodge, 360 Kms of over the hood snow all the time. Over 400 Kms on original belt. Adjusted it once. Did some good long pulls, never babied it a bit and to the bar for two days strait! Running on clicker 1 at 8100. Adjusted the chain three times and it's seems to have settled in. 12% left on break in. Super super happy with the sled. Had a couple of Polaris machines with us and they were amazed! I'm a pretty big guy to, 275 with gear and it pulls hard. Much much easier to handle than our 174. Feels like it has power steering! The only mods are revalved shocks and some stickers and powder coating! Lol just needs a bit of clutching and it's a keeper! Best sled I've ever owned! Oh yah, MBRP trail can to.
 
Last edited:

turboetech

Active VIP Member
Joined
Nov 8, 2011
Messages
854
Reaction score
1,243
Location
Alberta
Over 400 Kms now with original belt did a proper 50km break in on a trail best sled I have ever owned stock 100% satisfied
 

Kakwasledder

Active member
Joined
Feb 10, 2014
Messages
44
Reaction score
69
Location
Sexsmith
165 3 inch. As I like to break in both belts, I have 100km on first belt no problems, and 150 km on second belt no problems. Also the first belt has about 45 km pulling dead sled out on crappy trail conditions, and still looks good. One reason not to go out in early season.
 

Thistledoo

Active member
Joined
Sep 5, 2008
Messages
67
Reaction score
105
Location
Lethbridge Alberta
800 Kms and on belt 4. Blew the first one day one 58kms. Blew two in one day also. I have friends who ride way harder and have gone thru endless belts too. U guys who are not blowing them try riding in waist deep for 20 min wide open and tell me what u see...my T3 could do it no prob...this sled can't. My riding style or zones haven't changed....
 

Jake jenkins

Active VIP Member
Joined
Jan 28, 2012
Messages
820
Reaction score
792
Location
Alberta beach
Almost 800 km on original belt no issues yet , been riding Sicamous all week to the bar in waist deep snow


Sent from my iPhone using Tapatalk
 

teamdirt

Active VIP Member
Joined
Dec 17, 2008
Messages
692
Reaction score
1,075
Location
revy/sicamous
800 Kms and on belt 4. Blew the first one day one 58kms. Blew two in one day also. I have friends who ride way harder and have gone thru endless belts too. U guys who are not blowing them try riding in waist deep for 20 min wide open and tell me what u see...my T3 could do it no prob...this sled can't. My riding style or zones haven't changed....

first 300km in neck deep wide open throttle 90% of the time. no issues. not everyone is having issues- there is apparently some problem sleds but most are running fine.
 

Alpine_Bound

Active member
Joined
Dec 6, 2009
Messages
111
Reaction score
300
Location
Sparwood, BC
165 3"

Original belt exploded around 500 km.
Belt was gently broke in for 60 km, checked it every ride before it fell apart and it looked fine.
The day it failed was the first time I got to ride it hard for extended periods of time in knee to waist deep snow.
Collected all the pieces I could find and took them to my dealer in a bag, was told that I have to let the clutches cool down more often.
 

SidewaysInto3rd

Active VIP Member
Joined
Dec 30, 2009
Messages
1,351
Reaction score
2,603
Location
Sḵwxwú7mesh, BC
800 km .. 3 blown belts

165 3"

first 2 belts with stock belt guard
3rd belt with removed crap

clicker 1, max rev is 8200, but normally it pulls 8000 if i can see what that tiny gauge reads
 

Shredder

Active VIP Member
Joined
Dec 4, 2006
Messages
2,428
Reaction score
1,962
Location
Grande Cache AB
800 Kms and on belt 4. Blew the first one day one 58kms. Blew two in one day also. I have friends who ride way harder and have gone thru endless belts too. U guys who are not blowing them try riding in waist deep for 20 min wide open and tell me what u see...my T3 could do it no prob...this sled can't. My riding style or zones haven't changed....

Yep; that is 2012 Pro Climb 800 deja vu for me. Some sleds couldn't get out of the trailer on one belt; and some of us never had an issue. Only belt I ever blew on my 2012 or 2014 Pro Climbs was when I tried a softer secondary spring. That was my fault not Cats. Switched back to the stiffer spring and never had a issue. I also don't ride hard for long periods that can heat soak clutches and belts cause I am old and lazy now. I wonder if heat soaking due to higher clutch temps is part of the problem? Any old lazy guys that take frequent breaks having better luck?? Hope this gets sorted out soon. Good luck guys.
 
Last edited:

assaultn

Active VIP Member
Joined
Oct 25, 2008
Messages
513
Reaction score
764
Location
Sherwood Park
Stat update..... 27 sleds polled

9/27 have blown 1 or more belts(33.3% have belt issues)
10,508km logged on all 27 sleds
17 belts blown in total(389km average belt life)
4,280km logged on the 9 problematic sleds(251km average belt life on problematic sleds)
 

assaultn

Active VIP Member
Joined
Oct 25, 2008
Messages
513
Reaction score
764
Location
Sherwood Park
Sorry.... slight error in last post, wont let me edit for some reason

9/27 have blown 1 or more belts(33.3% have belt issues)
10,508km logged on all 27 sleds
17 belts blown in total(618km average belt life)
4,280km logged on the 9 problematic sleds(251km average belt life on problematic sleds)
 

dano30

Active member
Joined
Sep 9, 2010
Messages
86
Reaction score
56
Location
Slave Lake, Alb
154" 3" my first ride in vale with the new sled, 140km and 70% left for break in, frequent breaks and not a problem. damn does this thing pull like a mother f-----.
 
Last edited:

Keith Brown

Active VIP Member
Joined
Nov 12, 2014
Messages
649
Reaction score
1,631
Location
Okotoks Alberta
800 km .. 3 blown belts

165 3"

first 2 belts with stock belt guard
3rd belt with removed crap

clicker 1, max rev is 8200, but normally it pulls 8000 if i can see what that tiny gauge reads
Use the max rev setting it not hard to use and reset. I makes setting clicker easy.
 

LukeD

Active member
Joined
Jan 28, 2013
Messages
37
Reaction score
47
Location
Saskatchewan
Quick question. Of the sleds that have blown belts, how many were 2.5 vs 3 inch lugs? Also, how many sleds blowing belts were 154 vs 165? Thanks!
 

assaultn

Active VIP Member
Joined
Oct 25, 2008
Messages
513
Reaction score
764
Location
Sherwood Park
29 sleds polled now and you are the only 2.5". I assumed 165x3" for a couple as guys didn't specify. 6 154s in total and 3 are belt eaters. Looks like 154x3" may be the worst on paper but this is probably just from being wot more because of less track.
Quick question. Of the sleds that have blown belts, how many were 2.5 vs 3 inch lugs? Also, how many sleds blowing belts were 154 vs 165? Thanks!
 

KellyTataryn

New member
Joined
Nov 30, 2016
Messages
2
Reaction score
2
Location
Stonewall MB
154" x 2.5" no belt problems so far after 540km. Belt deflection and chain tension have been adjusted twice to meet spec along with the sled being de-foamed.
 
Top Bottom