any Kawasaki 750 Quad experts here

kenvb

Active VIP Member
Joined
Nov 7, 2006
Messages
1,100
Reaction score
2,008
Location
Whitecourt Alberta 780-778-2505
I had a 08 750 Brute Force come to me,was submerged in river for 3 days, got it all drained,changed oil 4 times before was clear.. But it wont idle,unplugged every elec connector and blew out and sprayed Electrical spray ..test drove about 2 kms, still doesnt idle..no adjustment on the FI system..
whats a reliable Kawi dealer to tell the owner to take it too..
 

modmanmike

Active VIP Member
Joined
Sep 9, 2009
Messages
3,418
Reaction score
819
Location
In a van by the river
There's a guy here in Hinton that specializes in kawi work. His company is called RPM. Rocky Performance Machines. His name is Mike. His #1 (780) 740-3154. He is the best I've found with kawi yet.
 

quadboy55

Active VIP Member
Joined
Dec 22, 2010
Messages
4,615
Reaction score
184
Location
Leduc, AB
If it was hydolocked it could have screwed with the valves, you should check the tolerances.
 

imdoo'n

Active VIP Member
Joined
Jan 15, 2008
Messages
52,123
Reaction score
40,091
Location
alberta
Wait who the fawk leaves a quad sit in a river for 3 days?

Talk to Tex78 he seems to know the machines fairly well

hmm tex may have left his machine a time or 2, he has some working knowledge on cowasakis. may be able to help?
 

Showtime

Active VIP Member
Joined
Oct 23, 2007
Messages
2,336
Reaction score
328
Location
Spruce Grove, AB
does it have the stock ecu or a dynatek? i have seen a few brutes running dynateks that wont idle.

I just got mine back from Chris @ Parkland Powersports due to idle issues and this was the exact culprit, faulty Dynateck Chip.

There's a guy here in Hinton that specializes in kawi work. His company is called RPM. Rocky Performance Machines. His name is Mike. His #1 (780) 740-3154. He is the best I've found with kawi yet.

I called him after reading this post very knowledgable guy.
 

MacMud

Member
Joined
Jun 15, 2011
Messages
14
Reaction score
0
Location
Fort Mac
I just went through this myself ...I thought I got all the water ...Im still finding it in some really hard spots to get out ...take all the controls on the bars off and check em for moisture... some WD40 - and seafoam in the fuel tank will help too ... one or the other will work fine ... Im thinking I will bring my quad to the desert for 3 days that may help dry it out !!
 

AreWeThereYet

Active VIP Member
Joined
Apr 4, 2009
Messages
12,781
Reaction score
7,573
Location
Grande Prairie
I worked on a buddies 650i tonight, won't fire but turns over. Has spark, air, fuel, valves good,.. so I pulled the rear head and the piston is about .050" below top of pot,.. I said hmm interesting, pretty sure your con rods are bent.

EDIT Con rods aren't bent,.. I guess that's how Kawai sets their crown clearance,.. ghey if you ask me,.. Anyways his rings are stuck in the lands,..
 
Last edited:

Sparky's

Active VIP Member
Joined
Sep 17, 2010
Messages
170
Reaction score
123
Location
Red Deer AB
The forum Mud In My Blood is a kawy site you can try out, they are a southern boys. They should know something.
 

imdoo'n

Active VIP Member
Joined
Jan 15, 2008
Messages
52,123
Reaction score
40,091
Location
alberta
The forum Mud In My Blood is a kawy site you can try out, they are a southern boys. They should know something.

i guess the quad god is not much good then, his shheeet is usually broken down eh!;):d:d:d:beer::beer:
 

Summiteer

Active VIP Member
Joined
Nov 8, 2006
Messages
5,884
Reaction score
3,506
Location
Whitecourt, Ab
Call Randy at RPM in Whitecourt, 780-706-2411 he ran a KVF 750 until last year. Most anything that could be broke on it has been and fixed by him.
 
Top Bottom